<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">On Fri, Aug 2, 2013 at 1:56 PM, Rafael EspĂ­ndola <span dir="ltr"><<a href="mailto:rafael.espindola@gmail.com" target="_blank" class="cremed">rafael.espindola@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div id=":cza" style="overflow:hidden">One exception we have in the coding standard is that classes that look<br>
like STL ones should use similar names for the methods (begin(),<br>
push_back(), etc...).<br>
<br>
But different parts of llvm have different opinions on how to handle<br>
the related case of classes that are not STL like, but have multiple<br>
collections that can be iterated over.<br>
<br>
* llvm/IR uses global_begin, alias_begin, etc. I.E., singular name + _begin().<br>
* llvm/Object uses begin_symbols, begin_sections, etc. I.E, begin_ +<br>
plural name.<br>
* others (YAML, LoopIterator) use beginSequence, beginFlowSequence, etc.<br>
<br>
I would like to propose adding the the format used by llvm/IR to the<br>
coding standard since it seems to be the most common.</div></blockquote></div><div class="gmail_extra"><br></div>Please do so. That is clearly the more consistent pattern to follow.<br><br></div></div>