[llvm-dev] JIT crashing when compiling source code with Clang and -mretpoline flag

Gaier, Bjoern via llvm-dev llvm-dev at lists.llvm.org
Thu Jun 27 22:51:55 PDT 2019

Heyho both Mailinglists,

I'm not sure if I encountered a bug or if I'm doing something wrong. I compiled a "Hello World"-function with Clang to LLVM-IR code, while passing the "-mretpoline" flag.

I tried jitting and calling that function with the KaleidoscopeJIT code, but when calling "lookup" for that function the application crashed.
I also tried that file in an old MCJIT implementation I had - there the application crashed when calling the function (but it does find the address for the function first).

If I recompile my code without the "-mretpoline" flag, everything works fine again.
I compiled Clang and the LLVM files from the LLVM8 source files, I run them under Windows7 64bit. Any ideas what might went wrong?

Kind greetings
Als GmbH eingetragen im Handelsregister Bad Homburg v.d.H. HRB 9816, USt.ID-Nr. DE 114 165 789 Geschäftsführer: Dr. Hiroshi Nakamura, Dr. Robert Plank, Markus Bode, Heiko Lampert, Takashi Nagano, Takeshi Fukushima. Junichi Tajika
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20190628/49617bd7/attachment.html>

More information about the llvm-dev mailing list