[llvm-dev] Problem with 'sed' on one Windows bot?

Davide Italiano via llvm-dev llvm-dev at lists.llvm.org
Tue Nov 7 15:12:29 PST 2017

On Tue, Nov 7, 2017 at 3:10 PM, Davide Italiano <davide at freebsd.org> wrote:
> On Tue, Nov 7, 2017 at 2:41 PM, Robinson, Paul via llvm-dev
> <llvm-dev at lists.llvm.org> wrote:
>> A test I added in r317607 is passing almost everywhere, except for
>> llvm-clang-x86_64-expensive-checks-win.  Other Windows bots are happy.
>> http://lab.llvm.org:8011/builders/llvm-clang-x86_64-expensive-checks-win/builds/6013
>> The test runs 'sed' on a file to generate variations of the input
>> assembler source for Linux and Darwin.  I have to say it looks like
>> 'sed' is being the problem on that one bot.  I reverted the test
>> because "don't argue with the bots" but... but... "It's not my fault!"
>> If anybody has any insight it would be greatly appreciated.
>> Thanks,
>> --paulr
> The short answer is that Galina should install the correct version of
> `sed` (presumably from gnuwin32) on that bot.
> The somewhat longer answer is that you could work around as Justin
> suggested, but I'm not sure what's your sed foo and/or whether it's
> worth going that route.

Side note: in my early days on Windows years ago I spent a good couple
of hours trying to figure out why some tests were failing, to discover
I had installed the wrong tool.
I don't recall whether the documentation points to the one true
version of sed/awk/* required, but in case it doesn't, maybe we might
consider adding it?


"There are no solved problems; there are only problems that are more
or less solved" -- Henri Poincare

More information about the llvm-dev mailing list