[llvm-dev] Adding [[nodiscard]] to Compiler.h

Justin Bogner via llvm-dev llvm-dev at lists.llvm.org
Sun Sep 4 18:40:13 PDT 2016


Chandler Carruth <chandlerc at google.com> writes:
> My 2 cents: get rid of LLVM_UNUSED_RESULT, and move to LLVM_NODISCARD.
>
> For compilers that support it, it should be a strict superset of features and
> functionality. The standard feature was written directly based on the clang
> warn_unused_result stuff.
>
> I would just migrate us onto the spelling and usage pattern that got
> standardized. All we have to lose are warnings from compilers other than Clang
> until they implement this feature. That seems like not a huge loss to me
> honestly.

You might be right. It seems a bit unfortunate that we'd lose these
warnings on MSVC and gcc for the time being, but maybe that's better
than the usability cost of having two macros that expand to the same
thing.

Do note though, if we do that this would mean clang is the only compiler
we can support this on at all without -std=c++17, since [[nodiscard]]
will trigger extension warnings in earlier standard modes.

> -Chandler
>
> On Sun, Sep 4, 2016 at 2:57 PM Sanjoy Das via llvm-dev <
> llvm-dev at lists.llvm.org> wrote:
>
>     Hi Justin,
>    
>     Justin Bogner wrote:
>      > Sanjoy Das<sanjoy at playingwithpointers.com>  writes:
>      >> Hi Justin,
>      >>
>      >> This SGTM generally, but please make the difference between
>      >> LLVM_NODISCARD and LLVM_UNUSED_RESULT clear in the code. :)
>      >
>      > Right, this is where it gets a little weird. LLVM_NODISCARD would be
>     for
>      > types, whereas LLVM_UNUSED_RESULT would be for functions. Depending on
>      > your host compiler, using the wrong one might DTRT, but it won't across
>      > all compilers.
>      >
>      > Do you think documenting this is sufficient, or should we try to name
>      > these to better represent where they should be used?
>    
>     Firstly, perhaps "LLVM_NODISCARD_TYPE" would be a better name?
>    
>     Secondly, if we define the following when the host compiler is clang,
>    
>     #define LLVM_UNUSED_RESULT __attribute__((warn_unused_result))
>     #define LLVM_NODISCARD_TYPE [[clang::warn_unused_result]]
>    
>     via some shallow manual testing, it looks like using
>     LLVM_NODISCARD_TYPE on a function should break the build (though I'd
>     love it if someone more familiar with clang chimed in on this). So, is
>     the problem that we can accidentally use LLVM_UNUSED_RESULT on a type
>     and not know it?
>    
>     I think there is a dirty trick here -- we could:
>    
>     #define LLVM_UNUSED_RESULT __attribute__((warn_unused_result, enable_if
>     (true, "")))
>     #define LLVM_NODISCARD_TYPE [[clang::warn_unused_result]]
>    
>     This breaks the (clang) build if LLVM_UNUSED_RESULT is used on a type.
>    
>     It would still be possible to not do the right thing on GCC or MSVC
>     and be able to build a binary, but I think as long as the clang bots
>     catch bad uses we're okay.
>    
>     -- Sanjoy`
>     _______________________________________________
>     LLVM Developers mailing list
>     llvm-dev at lists.llvm.org
>     http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev


More information about the llvm-dev mailing list