[llvm-dev] LNT Python problem?

Renato Golin via llvm-dev llvm-dev at lists.llvm.org
Tue Jun 28 12:10:08 PDT 2016

On 28 June 2016 at 19:34, Chris Matthews <chris.matthews at apple.com> wrote:
> I’m surprised how often this is happening.  I propose we lock all the dependency versions in LNT, and upgrade them on some cycle (maybe yearly). Otherwise this will happen every time we have a dependent package’s default version change.  We have always done this in the reqirements.txt file, and that has worked really well in our server deployments.

So, I thought about this being the same as last time, but here it's
>=, so unless they removed all versions newer than 0.82, this
requirement should work!

>> Requirement.parse('aniso8601>=0.82')

And funny enough, it worked on the next build... So, I don't really
think this is the same thing as before...

Could it be network problems? (and odd way to manifest, but...) That's
why I didn't create a bug, because it may very well be on my side.


More information about the llvm-dev mailing list