[llvm-dev] Can lit be upgraded to assume Python 2.7?

Sean Silva via llvm-dev llvm-dev at lists.llvm.org
Mon Feb 22 20:39:51 PST 2016

In the root llvm/CMakeLists.txt we have:

  message(FATAL_ERROR "Python 2.7 or newer is required")

But lit seems to still be stuck in a Python 2.5 world. For example,
detectCPUs is redundant now that we have multiprocessing.cpu_count()
(multiprocessing requires >=2.6). And there are a bunch of other Python 2.5
workarounds floating around inside lit. I'm actually not sure if there are
2.6 workarounds.

Anyway, does anybody know if somehow, despite the CMake check, lit is still
being run with Python <2.7 on any bots or anywhere? If not, I'd like to
make a couple cleanup patches.

-- Sean Silva
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20160222/856e0ea0/attachment.html>

More information about the llvm-dev mailing list