[llvm-dev] RFC: New function attribute "patchable-prologue"="<kind>"
Sanjoy Das via llvm-dev
llvm-dev at lists.llvm.org
Thu Apr 14 12:22:25 PDT 2016
Hi Dean, Eric,
Dean Michael Berris wrote:
> If I was going to suggest anything here, I'd like to think about a more
> general approach than a very specific attribute like this. My preference
> is something like "patchable-function"="kind,kind,..." (if that's even
> possible). This allows us to have common infrastructure for being able
> to implement different kinds of function-level patching routines at the
> same time or even just generalising this mechanism with the
> instrumentation attribute(s).
I've updated D19046 to use "patchable-function", can one of you please
take a look?
More information about the llvm-dev