[llvm-dev] How to pass march flag to GCC Assembler arch64-linux-gnu-as

Sri via llvm-dev llvm-dev at lists.llvm.org
Mon Oct 26 10:38:21 PDT 2015

Thanks alot Renato and Tim.
Yes i tried and it worked fine. I am just trying to figure out minimizing
my clags.

Thanks again.

On Mon, Oct 26, 2015 at 12:36 PM, Renato Golin <renato.golin at linaro.org>

> On 26 October 2015 at 17:31, Sri via llvm-dev <llvm-dev at lists.llvm.org>
> wrote:
> > I am trying to build chromium and at this moment, They see some issues
> with
> > internal one so recommended to use the flag -fno-integrated-as.
> Hi Sri,
> We were clearing all the bugs from the integrated assembler
> (https://llvm.org/bugs/show_bug.cgi?id=20422), so if you could try it,
> I'd love to hear how much we have progressed since the last time Hans
> tried, for both ARM and AArch64.
> > Manually running  /usr/bin/aarch64-linux-gnu-as -march=armv8-a+crypto -I
> gen
> > -I ../include -o MyFile.o MyFile.s works fine without any errors
> Have you tried -Wa that Tim suggested? It should work just fine.
> I agree Clang should pass down the architecture flags to the
> assembler, but we're assuming the external assembler will accept all
> variations Clang does, which may not be true.
> cheers,
> --renato

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20151026/44d274d9/attachment.html>

More information about the llvm-dev mailing list