[LLVMdev] [RFC] Raise minimum required CMake version to 3.0

David Chisnall David.Chisnall at cl.cam.ac.uk
Wed Mar 11 07:35:37 PDT 2015

On 11 Mar 2015, at 13:46, Renato Golin <renato.golin at linaro.org> wrote:
> On 11 March 2015 at 13:22, David Chisnall <David.Chisnall at cl.cam.ac.uk> wrote:
>> To put this in perspective, until the latest Ubuntu LTS release it had been impossible to build LLVM without building some dependencies manually on Ubuntu LTS.  This didn't seem to be a problem for the project then and I don't really see why it would become one now.
> You mean the GCC version? I don't run LTS, so I don't know. This is a
> good argument that makes the refusal even weaker.

The LTS that we were running shipped with CMake 2.8.7, so our old requirement of 2.8.8 broke it.  It also didn't ship with a gcc / libstdc++ that could build a recent LLVM.  I believe that the most recent Ubuntu LTS does meet all of the prerequisites for building LLVM head, but the previous one did not for at least a year of its life as the most recent supported LTS release.


More information about the llvm-dev mailing list