[LLVMdev] First-class debug info IR: MDLocation

Rafael EspĂ­ndola rafael.espindola at gmail.com
Sun Oct 26 19:30:16 PDT 2014

> Bike sheds to paint
> ===================
>  1. Should we trim some boilerplate?  E.g., it would be trivial to
>     change:
>         !6 = metadata MDLocation(line: 43, column: 7, scope: !4)
>     to:
>         !6 = MDLocation(line: 43, column: 7, scope: !4)
>     This would not complicate `LLParser`.  Thoughts?

I do prefer the simpler version. There is not a lot of value to saying
"metadata" all the time.

>  2. Which of the two "end goal" syntaxes is better: flat, or
>     hierarchical?  Better for what?  Why?
>     The flat one might be better for FileCheck-ing (not sure), but IMO
>     the hierarchical one is much saner for us humans, and that's the
>     main point of assembly.  It wouldn't be hard to default to one and
>     write the other based on a command-line flag -- is that a good idea?

We use an hierarchical structure in llvm-readobj, and it works really
well with FileCheck, so I would say hierarchical.

>  3. Assembly syntax is pretty easy to change, so this doesn't have to be
>     perfect now.  Nevertheless, is there a magical syntax that would be
>     easier to read/write/FileCheck?


More information about the llvm-dev mailing list