[LLVMdev] RFC: variable names

Chris Lattner clattner at apple.com
Mon Oct 13 16:00:20 PDT 2014

On Oct 13, 2014, at 3:44 PM, Chandler Carruth <chandlerc at google.com> wrote:
> I actually have a particular allergy to member variable names and function names having similar styles:
> bool x = i->isMyConditionTrue;
> Did I mean to write 'isMyConditionTrue()'? Or 'bool &x = I->isMyConditionTrue'? Or something else? I have no idea. Warnings and other things can help reduce the likelihood of this becoming a live bug, but it still makes the code harder to read IMO.

This is exactly why I was making the wishy-washy statement about instance variables.  This is the pattern that I tend to prefer:

class Something {
  bool IsMyConditionTrue;


  bool isMyConditionTrue() const { return IsMyConditionTrue; }

If you make instance variables be lower camel case, then you get serious conflict between ivars and methods.  Doing this also deflates some of the ammunition used by advocates of _ for ivars :-) 


More information about the llvm-dev mailing list