[LLVMdev] Windows Installer

Hans Wennborg hans at chromium.org
Fri Oct 3 14:47:17 PDT 2014

On Tue, Sep 30, 2014 at 3:44 PM, Hans Wennborg <hans at chromium.org> wrote:
> On Tue, Sep 30, 2014 at 1:00 PM, Eric Mader <emader at gmx.us> wrote:
>> I looked at the script some more. It seems that it only loops back to try
>> x64 if VS 2014 is installed - i.e. at the end of the :Found_V140 section it
>> does:
>>   set SUCCESS = 1
>> Since I don't have VS 2014 installed, :TRY_V140 falls through to :LOOPEND
>> which does:
>>   Set SUCCESS = 1
>> I added:
>>   set SUCCESS = 1
>> at the end of :TRY_V140 and now the script installs the x64 toolsets too.
> Thanks for figuring this out!
> I've committed a fix in r218712. I'll try to push a new snapshot build
> that includes it soon.

This is now available at

If you have time to try it out, please let me know if this fixes the
toolset install problem for you.

I'm still not sure about the "add to desktop" option, and I'm starting
to think maybe it never worked? The option to add LLVM to PATH seems
to work for me.


>>>> On 9/29/14, 3:59 PM, Hans Wennborg wrote:
>>>>> On Mon, Sep 29, 2014 at 10:52 AM, Eric Mader <emader at gmx.us> wrote:
>>>>>> I’m trying to install LLVM-3.6.0-r218288-win32.exe on Windows 7
>>>>>> Ultimate
>>>>>> x64. The install doesn’t complain, but the toolset doesn’t show up in
>>>>>> either
>>>>>> Visual Studio 2013 or Visual Studio 2010. Also I selected the choices
>>>>>> to
>>>>>> add
>>>>>> LLVM to the path for every user and put an LLVM icon on the desktop.
>>>>>> Neither
>>>>>> of this happened. Can anyone tell me how to get this to work?
>>>>> Hmm, your set-up sounds very similar to mine (Win 7, x64, a couple of
>>>>> visual studios), and I build the installer and it works for me.
>>>>> I wouldn't be too surprised if install.bat fails to find your Visual
>>>>> Studio installation. Can you share the paths where it's installed and
>>>>> where the existing toolsets reside?
>>>>> Not being able to install the desktop icon and set the PATH is more
>>>>> surprising.
>>>>> Did the installer run as administrator? It should, and it should pop
>>>>> up the UAC when it runs.
>>>>> Thanks,
>>>>> Hans

More information about the llvm-dev mailing list