[LLVMdev] [RFC] Requiring python 2.6

David Jones djones at xtreme-eda.com
Sat Dec 13 13:22:49 PST 2014

And to add to this,

gcc for Debian wheezy and Ubuntu 12.04 is too old to build LLVM >= 3.3

However, both of those platforms have Python 2.7.x as the standard install.

Python will not be your limiting factor here.

On Sat, Dec 13, 2014 at 8:39 AM, Dan Liew <dan at su-root.co.uk> wrote:
> >> Well, I am no Python expert either. I went with 2.7 because it was
> suggested
> >> and 4 years old software sounded old  enough.
> >
> > python 2.7 will be maintaned until 2020
> > (https://hg.python.org/peps/rev/76d43e52d978) so please leave it
> > as-is. People should be updating.
> I would also encourage making Python 2.7 the minimum. Distributions
> that move at glacial speed like RHEL6, CentOS6 and SLES11 can't even
> build LLVM out of the box due their out of date versions of gcc (4.4 I
> think) so I'm not convinced that arguments about avoiding "unnecessary
> hurdles for casual users to start getting involved in LLVM
> development" apply for these distributions. Anyone building LLVM on
> these platforms can only do so by investing effort into upgrading
> their C++ compiler. If they are willing to upgrade their compiler then
> I see no reason why they would resist installing a newer version of
> Python as well.
> _______________________________________________
> LLVM Developers mailing list
> LLVMdev at cs.uiuc.edu         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20141213/4c288de0/attachment.html>

More information about the llvm-dev mailing list