[LLVMdev] [RFC] Requiring python 2.6
chisophugis at gmail.com
Fri Dec 12 18:04:01 PST 2014
On Fri, Dec 12, 2014 at 7:51 AM, Rafael Espíndola <
rafael.espindola at gmail.com> wrote:
> So far two bots have complained about 2.7 (but have 2.6):
> Should we just upgrade those bots or reduce the requirement to 2.6?
2.6 + py3k is a generally good combination for typical code and is easy to
maintain. It is not possible to be both 2.5 and py3k compatible without
-- Sean Silva
> On 12 December 2014 at 06:41, Dan Liew <dan at su-root.co.uk> wrote:
> > +1
> > My view on this is that lit is a testing tool. If someone is competent
> > enough to build LLVM and run the tests then they're probably competent
> > enough to build a newer version of Python if for some reason they
> > can't obtain pre-built version.
> > I use lit outside of LLVM for several projects but I always use Python
> >>= 2.7 so it's not a problem for me.
> > I'd also be in favour of bumping the required version higher and require
> LLVM Developers mailing list
> LLVMdev at cs.uiuc.edu http://llvm.cs.uiuc.edu
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-dev