[LLVMdev] LLVM Loop Vectorizer puzzle
renato.golin at linaro.org
Thu May 23 15:40:17 PDT 2013
On 23 May 2013 19:26, Nadav Rotem <nrotem at apple.com> wrote:
> The history of the idvep pragma is fascinating. I did not know that it
> predated ANSI. People who care about cray compatibility should provide
> aliases for #ivdep. The name “ivdep” is simply terrible. There is no good
> reason not to come up with a syntax that is actually meaningful to people.
> I like arnold’s idea to add additional options so the ‘vector’ pragma.
I don't disagree. ;)
I think we should try to make #ivdep as close as possible to whatever the
original (or currently most used) meaning is, while enhancing and extending
the notion, where #ivdep can simply be a special case.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-dev