[LLVMdev] Unsupported MCJIT tests on ARM?

Renato Golin renato.golin at linaro.org
Sat May 18 01:38:38 PDT 2013

Hi folks,

Three MCJIT tests are failing on both our buildbots (check-all and
self-host) and I'm not sure what's the best way to fix it.

Some test passes, some not on { A9, A15 } x { Ubuntu 12.10, Ubuntu 12.04 },
the error is:

void llvm::RuntimeDyldELF::resolveARMRelocation(const llvm::SectionEntry&,
uint64_t, uint32_t, uint32_t, int32_t): Assertion `(*TargetPtr &
0x000F0FFF) == 0' failed.
Stack dump:
0. Program arguments: /home/user/devel/llvm/build/bin//lli -use-mcjit

Since the test is marked as XFAIL on ARM, I suspect this is expected, and
I'm surprised that it stopped failing on some runs and not others. Are they
meant to be supported? Are they meant to be passing? Failing?

Most tests pass, and I understand MCJIT is being worked on for ARM, so
there's no reason to mark the whole directory unsupported on ARM, but would
be good if the flaky behaviour was marked unsupported until properly

I tried to add "UNSUPPORTED: arm" according to the docs, but it seems it's
not making much difference. Any ideas? Should we move the "remote" tests to
their own directory and mark that as unsupported? But, to be honest, if
it's easy to fix, I'd rather someone fixed it for good.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20130518/a71e09f8/attachment.html>

More information about the llvm-dev mailing list