[LLVMdev] [vmkit] Errors compiling vmkt

Jiong Wang jiwang at tilera.com
Thu Mar 7 20:49:19 PST 2013

on 2013/3/1 6:11, Gaël Thomas wrote:
> Fundamentally, I think that for the VMKit project, it's important to
> be hosted as a subproject of llvm because VMKit heavily relies on llvm
> (and because llvm is maybe a little bit more attractive than inria:)).
> So, we will quickly re-merge the two projects and continuously
> integrates the stable (and interesting) contributions of the inria
> research project inside the llvm repository. We will also merge the
> web pages and forget this stupid idea of VMKit2 (I will still keep a
> separated repository hosted by inria for unstable or too specific
> developments).
> To conclude, we were a little bit overloaded these last weeks and we
> have delayed the merge, but we will work on this soon (probably before
> the end of march). For the moment, you should use the VMKit2
> repository as it's probably the most advanced one.

Hi Gael,

   does it mean vmkit will based on the latest llvm after the merge 

   I run into the same issue Chris meet when trying to verify tilegx 
backend by compiling vmkit.

  JavaJIT.cpp:1262:23: error: no member named 'removeFnAttr' in

   then I change to vmkit2, but found it's based on 3.2 only, failed 
compile with latest llvm

> See you,
> Gaël
> 2013/2/24 Minas Abrahamyan <minas.subs at gmail.com>:
>> Hi Harris,
>> A question has arisen, what is the difference between VMKit2 and VMKit,
>> and why, in the first place the new VMKit2 fork was been created?
>> Thanks for answer :)
>> Best regards,
>> Minas
>> On Tue, Feb 12, 2013 at 2:36 PM, Harris Bakiras <h.bakiras at gmail.com> wrote:
>>> Hi Chris,
>>> For the moment you can install VMKit following these instructions:
>>>      http://vmkit2.gforge.inria.fr/start.php
>>> VMKit's web page and repository will be updated soon.
>>> Harris Bakiras
>>> Le 12/02/2013 10:30, chris.gray at kiffer.be a écrit :
>>>> Hi all,
>>>> I hope this is the correct place to post such questions?  I am building
>>>> vmkit for the first time, following the instructions on the get_started
>>>> page (with one deviation: in step 4 I ran ./configure in my vmkit
>>>> directory and therefore did not need to cd at the start of step 5.  Is
>>>> this correct?). Build platform is 64-bit CrunchBang Linux 11 "Waldorf",
>>>> based on Debian Wheezy.
>>>> I get some compilation warnings, which could be harmless, followed by an
>>>> error:
>>>> chris at forbesy:~/vmkit$ make ENABLE_OPTIMIZED=1llvm[0]: Constructing
>>>> LLVMBuild project information.
>>>> make[1]: Entering directory `/home/chris/vmkit/lib/vmkit/StaticGCPass'
>>>> make[3]: Entering directory `/home/chris/vmkit/lib/j3/VMCore'
>>>> make: *** [all] Error 1
>>>> Did I do something wrong?
>>>> Regards
>>>> Chris
>> _______________________________________________
>> LLVM Developers mailing list
>> LLVMdev at cs.uiuc.edu         http://llvm.cs.uiuc.edu
>> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

More information about the llvm-dev mailing list