[LLVMdev] Build Clang and LLVM on Win 8

Giorgio Franceschetti g.franceschetti at vidya.it
Sun Jul 21 12:32:01 PDT 2013

Hi all,
   I'm new to Clang and LLVM and I'd like to use them on Win 8 with 

I'm having problems in running cmake.

I did the following:

  * Installed cmake
  * installed Code::Blocks
  * Installed python (cmake was complaining if it was not installed)
  * Dowloaded sources fron svn (LLVM, clang, compilre-rt and test-suite.

When I run cmake I got The following error:
*<project folder>\build>CMake -G "CodeBlocks - MinGW Makefiles" ..\llvm*
/-- Could NOT find LibXml2 (missing:  LIBXML2_LIBRARIES 
//-- Target triple: x86_64-w64-mingw32//
//-- Native target architecture is X86//
//-- Threads enabled.//
//-- Found PythonInterp: C:/Python33/python.exe (found version "3.3.2")//
//-- Constructing LLVMBuild project information//
//CMake Error at CMakeLists.txt:299 (message)://
//  Unexpected failure executing llvm-build: Traceback (most recent call 
//    File "<project folder>/llvm/utils/llvm-b//
//uild/llvm-build", line 3, in <module>//
//      import llvmbuild//
//    File "<project folder>\llvm\utils\llvm-b//
//uild\llvmbuild\__init__.py", line 1, in <module>//
//      from main import main//
//  ImportError: No module named 'main'//
//-- Configuring incomplete, errors occurred!/

So I thought that I missed to configure something.
I tried to run the configure script as per the web instructions, but I 
got an error because the configure script is only for linux

*<project folder>\build>..\llvm\configure --p**refix="c:\llvm\tools"*/
//"..\llvm\configure" is not an internal/external command, an executable 
or batch file.///

May anyone please help me?
I downloaded the last version of LLVM (3.4).

Thanks in advance,
   Giorgio Franceschetti
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20130721/8f7c217c/attachment.html>

More information about the llvm-dev mailing list