[LLVMdev] Failure building llvm/clang from source using binary clang package on Mageia 2

Edward Diener eldlistmailingz at tropicsoft.com
Wed Jan 16 17:48:11 PST 2013

On 1/15/2013 9:42 PM, Dmitri Gribenko wrote:
> On Wednesday, January 16, 2013, Edward Diener wrote:
>     On 1/15/2013 11:19 AM, Dmitri Gribenko wrote:
>         On Mon, Jan 14, 2013 at 3:32 AM, Edward Diener
>         <eldlistmailingz at tropicsoft.com> wrote:
>             It is on pastebin and is called ConfigureLog. I made it
>             private, FWIW.
>         Please provide a link.  I can not find it because it is private.
>     I copied it to a public paste called ConfigureLogPublic at
>     http://pastebin.com/yaLHmmGk.
> I see that this clang has problems with parsing unwind.h.  I don't
> understand how does it manage to compile LLVM/Clang.

It did previously without errors but some warnings.

>         Anyway, attached is a patch that should allow old clangs that don't
>         implement __has_include.  Please test.
>     Thanks ! If not implementing __has_include does not keep the clang
>     package from working correctly, why would it be part of the
>     "configure" script ?
> Sorry, I did not quite get it.

I don't know what "__has_include" is but evidently it is not necessary 
for the compiler to successfully be used to build clang from source. So 
it seems to me that the 'configure' script should still allow that the 
compiler can be used to build clang without "__has_include".

I tried your latest patch but it still did not allow me to use clang 
under CentOS 6.3. I still get:

checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether clang accepts -g... yes
checking for clang option to accept ISO C89... none needed
checking whether we are using the GNU C++ compiler... yes
checking whether clang++ accepts -g... yes
checking how to run the C preprocessor... clang -E
checking whether clang works... no
configure: error: Selected compiler could not find or parse C++ standard 
library headers.  Rerun with CC=c-compiler CXX=c++-compiler ./configure ...

More information about the llvm-dev mailing list