[LLVMdev] [cfe-dev] RFC: Codifying (but not formalizing) the optimization levels in LLVM and Clang
rikka at google.com
Mon Jan 14 13:46:08 PST 2013
On Mon, Jan 14, 2013 at 1:30 PM, <dag at cray.com> wrote:
> Chandler Carruth <chandlerc at gmail.com> writes:
> > minsizeopt
> > sizeopt
> > quickopt
> > opt
> > maxopt
> I prefer being consistent and putting "opt" at the end.
> I would still like something other than "opt" for the fourth one. "opt"
> seems too generic given the other levels.
I agree that having just "opt" seems too generic in comparison. Maybe
something like "stdopt" (or even the longer "balancedopt") since it
corresponds to -O2 and is intended to represent a good optimization level
for most cases with a balance of compile time, space, and runtime
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-dev