[LLVMdev] Renaming MCInstFragment to MCRelaxableFragment
eliben at google.com
Fri Jan 4 08:24:05 PST 2013
On Thu, Jan 3, 2013 at 7:16 PM, Rafael Espíndola
<rafael.espindola at gmail.com> wrote:
>> I don't know what a more suitable name would be. Any ideas?
> I initially thought MCRelaxedFragment would go well with
> MCRelaxableFragment, since a MCRelaxableFragment is merged into a
> MCRelaxedFragment once we are done relaxing it.
> The problem is that both names are really similar.
Yes, having two such similar names would definitely be confusing. An
additional problem with MCRelaxedFragment is that it's used for
completely relaxation-unrelated things like .data and .byte, where
MCDataFragment actually makes sense. To conclude, I think that leaving
MCDataFragment named as it is isn't a bad option for now; it can
always be renamed if we come up with a better name in the future.
More information about the llvm-dev