[LLVMdev] Size of structs & arrays

Fraser Cormack frasercrmck at gmail.com
Sat Feb 25 12:13:00 PST 2012

Fraser Cormack wrote:
> This is working, too, however I'm getting a segmentation fault at runtime.

Okay so I've delved a bit deeper, and run this program with lli
--force-interpreter and it gets this result:

   LLVM ERROR: Tried to execute an unknown external function: memcpy

I've read that one has to install libffi then re-configure and reinstall
llvm, however this hasn't worked for me. Perhaps I need to link it somehow,
but anyway.

I've also run the program with lli -debug and this is the end result:

********** Stack Slot Coloring **********
********** Function: java/lang/Object::<init>()
******** Post-regalloc Machine LICM: java/lang/Object::<init>() ********
Machine Function
********** Function: java/lang/Object::<init>()
JITTing function 'java/lang/Object::<init>()'
JIT: Starting CodeGen of Function java/lang/Object::<init>()
JIT: Emitting BB0 at [0x7f09970c8140]
JIT: Finished CodeGen of [0x7f09970c8140] Function:
java/lang/Object::<init>(): 1 bytes of text, 0 relocations
JIT: Binary code:
JIT: 0: 195
SectionIdx: 0, Name: , Size: 0, Offset: 0, SectionData Size: 0
SectionIdx: 1, Name: .text, Size: 1, Offset: 64, SectionData Size: 1
SectionIdx: 2, Name: .eh_frame, Size: 64, Offset: 65, SectionData Size: 64
SectionIdx: 3, Name: .data, Size: 0, Offset: 129, SectionData Size: 0
SectionIdx: 4, Name: .bss, Size: 0, Offset: 129, SectionData Size: 0
SectionIdx: 5, Name: .strtab, Size: 52, Offset: 129, SectionData Size: 52
SectionIdx: 6, Name: .symtab, Size: 168, Offset: 184, SectionData Size: 168
SectionIdx: 7, Name: .shstrtab, Size: 54, Offset: 352, SectionData Size: 54
Segmentation fault

So this information doesn't really help or mean much to me. Any help is, of
course, much appreciated :)

View this message in context: http://old.nabble.com/Size-of-structs---arrays-tp33341964p33392056.html
Sent from the LLVM - Dev mailing list archive at Nabble.com.

More information about the llvm-dev mailing list