[LLVMdev] How to enable cbe as a supported target?

Mingliang LIU liuml07 at gmail.com
Wed Dec 5 08:00:30 PST 2012

Hi all,

I met an error when I run the llc command to transform a bitcode file to C
code (source to source):
$ llc -march=c -o foo.c foo.ll
However, it said "*llc: error: invalid target 'c'.*" I checked the 'llc
--version' only to find that there is no *c* as target. The *cpp* was
there, which makes calls against the LLVM C++ API. But that's not what I

I configured my LLVM with default options, thus I supposed the 'cbe' should
have been enabled as a supported target. Nevertheless, I tried to enable it
$ ../configure --enable-targets=cbe
It occurred the error: "*configure: error: Unrecognized target cbe*"

Any clue?

Thank you.
Mingliang LIU (刘明亮 in Chinese)

PACMAN Group,  Dept. of Computer Science & Technology
Tsinghua University, Beijing 100084, China
Email: liuml07 at mails.tsinghua.edu.cn
Homepage: http://pacman.cs.tsinghua.edu.cn/~liuml07/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20121206/c2da53a2/attachment.html>

More information about the llvm-dev mailing list