[LLVMdev] Minimum Python Version
baldrick at free.fr
Mon Dec 3 17:49:27 PST 2012
On 04/12/12 00:28, Sean Silva wrote:
> On Mon, Dec 3, 2012 at 6:56 AM, Tobias Grosser <tobias at grosser.es> wrote:
>> The gcc compile farm currently only has python 2.4 and 2.5. I know Duncan is
>> using it quiet extensively, especially all dragonegg buildbots run on it.
>> I very much agree we should ensure our python scripts are valid python 2.7
>> and as close as possible to python 3.x. However, as Daniel pointed out,
>> there are still users of older python versions around. We could probably
>> require them to upgrade, but I would like to avoid this, if we
>> can support older python versions without too much trouble.
> Duncan, sorry for roping you into this thread, but it seems that your
> bots are basically the only concrete need that has been voiced for
> supporting End-of-life'd (2.4, 2.5) Python versions. Do you have any
> plans for bringing those bots up to 2.6 or 2.7?
most of the bots are running 2.5.2, because that's the system python version
(Debian lenny). I don't have any control over the O/S version, so I would
have to install a more recent python version locally. Personally I think it
is wise to have buildbots running on older systems, since I reckon that there
are many people running oldish systems out there. Lenny came out in 2009, and
was the latest stable Debian release until 6 months ago, so it's not even that
If it wouldn't take
> you a long time, I think it would be beneficial to update so that our
> Python code can be made Python2+Python3 compatible; Arch Linux and I
> believe Ubuntu 12.10 ship with Python3 as /usr/bin/python by default,
> so being able to coexist with both is important.
What is the reason for upgrading? Is there a problem with python 2.4/2.5 that
can't be worked around?
More information about the llvm-dev