[LLVMdev] Minimum Python Version

Eli Bendersky eliben at google.com
Sat Dec 1 14:14:32 PST 2012

On Sat, Dec 1, 2012 at 2:08 PM, Dimitry Andric <dimitry at andric.com> wrote:
> On 2012-12-01 21:57, Gregory Szorc wrote:
>> I'd like to continue the discussion about minimum Python versions from the
>> "Use multiprocessing instead of threading" thread in its own thread because
>> I feel it warrants additional discussion.
> ...
>> For these reasons, I urge LLVM to drop support for Python older than 2.6.
>> I would encourage requiring 2.7 (preferably the latest available release -
>> 2.7.3 at this time) at the earliest convenience, but I'm not explicitly
>> asking for it. While continued support for older Pythons is a noble goal and
>> may continue to support people clinging to ancient Python releases, this
>> will only make the path forward more difficult, as it puts an additional
>> burden on those maintaining Python in the tree.
> That is all well and good, but please be reminded there are zillions of Red
> Hat (or CentOS) users out there, stuck with either Python 2.5 or 2.6, who
> cannot easily upgrade without busting their whole system...
> ___________________

To install a new Python version one doesn't have to "upgrade" and
surely not "bust" their whole system! You can install a newer version
of Python alongside older ones, and if everything else fails you can
just install it locally and use *that* to run the Python scripts LLVM
requires. It's quite easy to set up.


More information about the llvm-dev mailing list