[LLVMdev] problems naming a function

Eli Friedman eli.friedman at gmail.com
Wed Sep 14 18:50:43 PDT 2011


On Wed, Sep 14, 2011 at 6:39 PM, ret val <retval386 at gmail.com> wrote:
> I created a new Function in code(for a pass), and now I want to name
> it to make the IR more readable.
>
> Function inherits GlobalValue, which eventually inherits Value. Value
> has the setName() method. When I do this on my new
> function(newFunc->setName(string("testing"))) I get back "error:
> ‘setName’ was not declared in this scope". What is the correct way
> todo this?

setName is correct.

-Eli




More information about the llvm-dev mailing list