[LLVMdev] AVX Naming

David Greene dag at cray.com
Fri Oct 7 16:02:38 PDT 2011

When Bruno designed the AVX spec, it looks like he created names like:


to distinguish 128-bit and 256-bit operation.  It's sort of become a
personal hobby of mine to curse the binutils maintainers for
"vcvtpd2psy" because it's so easy to miss the trailing suffix on a quick

I find that same trouble reading dumps with the current AVX names.
Before regalloc it is harder to determine the vector length of an
instruction at a glance.

To overcome that, I started using a naming convention of:


What do people think?  I realize it's "only" naming but when scannig
debug dumps I've found it really helpful to quicky determine how
something was vectorized.  From a performance debugging standpoint,
vector length is often an indication of problems or missed

I'm willing to do a gradual mechanical change if this seems reasonable
to people.


More information about the llvm-dev mailing list