[LLVMdev] Unable to run a java class by j3

Sarah sarah.berenji at gmail.com
Wed Jul 27 05:35:17 PDT 2011

Nicolas Geoffray <nicolas.geoffray <at> gmail.com> writes:

> Hi Sarah,
> On Sun, Jul 24, 2011 at 6:28 AM, Sarah <sarah.berenji <at> gmail.com> wrote:
> I created links in "/usr/local/classpath/lib" where my classpath objects are
> installed. Since it didn't work I tried these paths too: in classpath's source
> "/usr/local/classpath-0.97.2/lib" & also in "/lib"!! The error didn't change.
> As another solution, I used gcc-4.1 to compile classpath. But it didn't work
> too.
> Here is my configure options:
> ./configure --with-llvmsrc=/usr/local/llvm-2.9 --with-gnu-classpath-
> glibj=/usr/local/classpath/share/classpath --with-gnu-classpath-
> libs=/usr/local/classpath/lib  --with-llvmobj=/usr/local/llvm-2.9
> I suggest not installing gnu classpath, but just work on the local directory 
where you compiled it. At the end of the compilation process, you should have:
> .../classpath-0.97.2/lib/*.so
> .../classpath-0.97.2/lib/glibj.zip
> Using "--with-mmtk-plan" returns the following error: "configure: error:
> /bin/bash .//autoconf/config.sub org.mmtk.plan.marksweep.MS failed", so I
> committed it assuming it will use the default value.
> It will get the default which is  org.mmtk.plan.marksweep.MS, but the 
configure error is strange. Could you try with another collector?
> Nicolas

Sorry for delay in response. As you suggested, I didn't install classpath & 
thankfully it works!!

cd classpath-0.97.2
./configure CC=/usr/bin/gcc-4.1 --disable-plugin --disable-examples --disable-
cd lib
ln -s ../native/jni/java-lang/.libs/libjavalang.so; (and so on)

cd vmkit-0.29
./configure --with-llvmsrc=/usr/local/llvm-2.9 --with-gnu-classpath-
glibj=/usr/local/classpath-0.97.2/lib --with-gnu-classpath-
libs=/usr/local/classpath-0.97.2/lib  --with-llvmobj=/usr/local/llvm-2.9  --
cd Release/bin/
./j3 Hey

About "--with-mmtk-plan", in my previouse installations, all other collectors 
return the same error. But this time (which classpath didn't install) I used 
org.mmtk.plan.copyms.CopyMS & everything runs well :)
Thanks for your help :)

More information about the llvm-dev mailing list