[LLVMdev] MCLoggingStreamer enhancements

Michael Spencer bigcheesegs at gmail.com
Wed Oct 6 13:53:10 PDT 2010


On Sun, Sep 26, 2010 at 4:02 PM, Nathan Jeffords
<blunted2night at gmail.com> wrote:
> Hi guys,
> Attached is a set of patches that adds detailed argument information to the
> output of the MCLoggingStreamer that may be enabled when outputting an
> object file from llc or llvm-mc. It is broken into three pieces.
> The first patch allows a MCSection to report a name to be used for
> diagnostic purposes.

I'm not sure if it may be a better idea to just make getSectionName
virtual in the base class instead of adding a new getName function
that just forwards to getSectionName in each subclass. Although
getName is more consistent with the rest of the MC api.

I propose that we make getSectionName virtual in the base class and
then rename it to getName as it's more consistent and we already know
it is a section because of its type.

> The second patch updates MCLoggingStreamer to enhance its output.

LGTM.

> This third patch enhances the output for instruction in
> the MCLoggingStreamer.

I think OwningPtr would fix the problems here. Just have the logging
streamer be responsible for deleting the printer.

- Michael Spencer

> The first two patches are ready to go in my opinion. But the third doesn't
> deal with ownership of the instruction printer correctly I think, and it
> maybe too much for what it gives back.
> -Nathan
> _______________________________________________
> LLVM Developers mailing list
> LLVMdev at cs.uiuc.edu         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
>
>




More information about the llvm-dev mailing list