[LLVMdev] vmkit build problems

chanwit chanwit at gmail.com
Wed Jul 7 09:50:19 PDT 2010


Just to comfirm that I have just clean built the current LLVM and VMKIT
revisions and it failed too.
The problem seems to be the same one (about escape analysis in LLVM).
My configuration is Ubuntu 10.04 and GCC 4.4.3 on x86.



Konrad Hinsen-2 wrote:
> On 6 Jul 2010, at 22:25, Zoe Wolk wrote:
>> If anyone is able to build vmkit and get it to run without a  
>> segfault (for any
>> distro/arch), using mmtk or the default collector/installation (as  
>> described in the vmkit page or
>> Alysson's writeup) using the svn head of llvm and vmkit, please let  
>> me know.
> I had a working installation of VMKit dating from April, running on  
> MacOS X 10.5. Back then, I worked from the installation instructions  
> on the VMKit Web site. Today I updated both LLVM and VMKit to the  
> current svn revisions and recompiled (without touching the  
> configuration). This fails due to a problem with escape analysis that  
> you seem to have worked around already.
> Unfortunately I am too busy at the moment to pursue this any further!
> Konrad.
> _______________________________________________
> LLVM Developers mailing list
> LLVMdev at cs.uiuc.edu         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

View this message in context: http://old.nabble.com/vmkit-build-problems-tp29030093p29098623.html
Sent from the LLVM - Dev mailing list archive at Nabble.com.

More information about the llvm-dev mailing list