[LLVMdev] Problems with lli and hello.c

Samuel Crow samuraileumas at yahoo.com
Thu Jun 25 11:44:02 PDT 2009

Jello Juan,

The interpreter is quite useless in its current state.  Try using a JIT compiler for you computer from the lli command and it should work.


>From: Juan Carlos Martinez Santos <juanc.martinez.santos at gmail.com>
>To: LLVM Developers Mailing List <llvmdev at cs.uiuc.edu>
>Sent: Thursday, June 25, 2009 1:04:17 PM
>Subject: [LLVMdev] Problems with lli and hello.c
>I just install the new newest version of LLVM. When I ran the hello.c example I got the below message. Somebody has an idea what is wrong? The problem is just with lli, the other commands worked as I expected.
>:~/LLVM/my-test$ lli hello.bc
>Tried to execute an unknown external function: i32 (i8*)* puts
>0   lli 0x0861fab8
>Stack dump:
>0.    Program arguments: lli hello.bc 
>Thanks in advance.
>Juan Carlos 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20090625/2d073abc/attachment.html>

More information about the llvm-dev mailing list