[LLVMdev] maintaining names for types

Mike Stump mrs at apple.com
Wed Oct 29 16:32:12 PDT 2008

On Oct 29, 2008, at 10:50 AM, Scott Graham wrote:
> Relatedly, it would be convenient to have a way to reliably influence
> which name gets chosen for the merged type. If I could at least have
> things like "%ObjHeader" not turn into
> "%SomeUserCodeType_NestedUserClass_Blorp", that would go a long way.

What rule would you use to pick between the two?  min(strlen)?   
First?  Last?  min(wc -w)?  If you had a way to pick, people might go  
along with it...  :-)

More information about the llvm-dev mailing list