[LLVMdev] [patch] add support for PIC on linux x86-64

Evan Cheng evan.cheng at apple.com
Fri Jun 6 12:25:40 PDT 2008


On Jun 6, 2008, at 11:55 AM, Dan Gohman wrote:

> On Fri, 2008-06-06 at 17:08 +0100, Rafael Espindola wrote:
>> 2008/6/6 Anton Korobeynikov <asl at math.spbu.ru>:
>>> Hello, Rafael
>>>
>>> Awesome! But... -ENOPATCH :(
>>
>> Attached now.
>
> Hi Rafael,
>
> Thanks a lot for working on this!
>
> I have one question about the patch; why did you choose too add a new
> enum, PICCallStyle, instead of reusing (possibly with some  
> adjustments)
> the existing PICStyle enum?

Yes, please remove PICCallStyle and have printPLT check for pic  
relocation model and Subtarget.isTargetELF().

And where you are modifying this part of the code. Please rename  
printGOT, printStub, and printPLT to something that indicates they are  
predicate functions. Perhaps shouldPrintGOT, etc.?

Thanks,

Evan

>
>
> Thanks,
>
> Dan
>
>
> _______________________________________________
> LLVM Developers mailing list
> LLVMdev at cs.uiuc.edu         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev




More information about the llvm-dev mailing list