[LLVMdev] release tag policy

Chris Lattner sabre at nondot.org
Tue Feb 13 15:23:33 PST 2007

On Tue, 13 Feb 2007, John T. Criswell wrote:
>> I don't care about correcting this for the 1.9 release, and I don't really
>> think that overloading RELEASE_19 and release_19 is a good idea, but
>> please work together and figure out a policy that makes sense.
> Switching to another naming convention might be a good idea; it seems
> it's causing confusion.

I agree.

> Since Tanya is the release manager now, I'll defer to her judgement.  If
> you'd like me to draft up the conventions I used, please let me know.

I propose that Tanya write up a summary of the 'rules' and pick a naming 
convention, sending it to this list.  That way she can get feedback from 
you (and others) and the wording can be folded into the new Developer 
Policy doc.

Sound reasonable Tanya?

Isn't it great that LLVM is growing to the point where people care about 
these things? :)



More information about the llvm-dev mailing list