[LLVMdev] lli problem in llvm

Joy W. Kamunyori jkamunyori at cs.virginia.edu
Thu Feb 1 12:52:18 PST 2007


I've just downloaded and installed LLVM, and am trying to invoke the JIT 
using the "lli" command. Using the example given on the LLVM webpage, I 
created a simple hello.c file as follows:

 #include <stdio.h>
   int main() {
     printf("hello world\n");
     return 0;

I was able to successfully compile it using llvm-gcc and to run the 
resulting executable. The problem comes in when I try to invoke the JIT. 
As instructed, I created a hello.bc file in the following way: 
llvm-gcc -O3 -emit-llvm hello.c -c -o hello.bc

When I try to run "lli hello.bc", I get the following error:
Error loading program 'hello.bc': Don't know how to deserialize 
primitive type 16 (Vers=0, Pos=15)

I also tried invoking the JIT using the example .bc file in the test 
suite (very-long-byte-name.bc), but I get the same error.

Do you know what this means, and how I can fix it?

Joy Kamunyori


Joy W. Kamunyori
Graduate Student - Computer Science Dept.
University of Virginia
jkamunyori at cs.virginia.edu

"Life must be understood backwards; but... it must be lived forward."
Soren Kierkegaard

More information about the llvm-dev mailing list