[LLVMdev] compilation failure on OS X powerpc

Chris Lattner sabre at nondot.org
Thu Apr 12 16:22:10 PDT 2007

On Thu, 12 Apr 2007, Ryan M. Lefever wrote:
> The reason I didn't use Xcode 2.4 is because I'm running OS X 10.3.9
> (Panther).  I have not upgraded the OS to 10.4.  Xcode 2.4 requires OS X
> 10.4, according to Apple's website.  Do you know otherwise?  I think the
> highest Xcode I can get is 1.5.

Okay, good point.

> By the way what does FSF mean?

An official gnu compiler.

> I also tried compiling llvm with the gcc 3.3 that comes with OS X 10.3,
> and it gave the exact same error when compiling Program.cpp.

Okay, I don't know. :)


> Chris Lattner wrote:
>> On Thu, 12 Apr 2007, Ryan M. Lefever wrote:
>>> I have an ibook G4 (powerpc) running OS X panther.  I am using gcc 4.0.3
>>> installed from Darwin Ports to compile llvm.  When I try to compile
>>> llvm, I get the following error:
>>> llvm[1]: Compiling Program.cpp for Debug build
>>> Unix/Program.inc: In function 'void llvm::SetMemoryLimits(unsigned int)':
>>> Unix/Program.inc:127: error: 'RLIMIT_AS' was not declared in this scope
>> I don't know much about darwin ports.  I assume it's an FSF version of
>> GCC?  If so, I strongly recommend against using it.  FSF GCC has a number
>> of minor ABI differences with Apple GCC.  I'd strongly suggest getting and
>> installing Xcode 2.4, it is free and well supported.
>> -Chris



More information about the llvm-dev mailing list