[LLVMdev] gccas problem with crtend.ll again

Anderson, Todd A todd.a.anderson at intel.com
Tue Oct 10 15:40:17 PDT 2006

> On Thu, 20 Apr 2006, [UTF-8] Rafael Esp?ndola wrote:
> > I am trying to bootstrap the just released gcc 4.0.1 and the cvs
head llvm.
> >
> > I was able to build the llvm tools without a problem.
> > gcc has a small problem (from the apple branch IIRC): libojc is
> > unconditionally, so objc must be in the --enable-languages option
> > the build to be successful.
> >
> > Building the rest of llvm fails with
> >
> > llvm[3]: Compiling crtend.ll to crtend.bc for Debug build (bytecode)
> > /home/rafael/dev/obj/Debug/bin/gccas:
> > /home/rafael/dev/obj/runtime/GCCLibraries/crtend/Debug/crtend.ll:1:
> > syntax error, unexpected $undefined
> > /home/rafael/dev/obj/runtime/GCCLibraries/crtend/Debug/crtend.ll:1:
> > while reading token: '.'
> >
> > I believe that this is because the -emit-llvm-bc option is not
> > as before (true x86 assembly is generated).
> Try rerunning configure with the newly built llvm-gcc in your path.
> configure script should detect that you have llvm-gcc4 and disable 
> building these libraries (which are only needed by llvm-gcc3).

I am having the same problem.  I built llvm tools then cfrontend then
went back to llvm, did a re-configure and did a make and I still get
the same error.

Any other pointers anybody can give me?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20061010/bb779c87/attachment.html>

More information about the llvm-dev mailing list