[LLVMdev] Re: Release 1.6 LLVM-Cfrontend build error on cygwin

Chuck chucking at sjtu.org
Tue May 16 07:03:14 PDT 2006

Chris Lattner <sabre <at> nondot.org> writes:

> On Sun, 14 May 2006, JinTao wrote:
> > 	Deeply confused now. Anyone coming for help?
> I don't really know anything about the cygwin port, but can you try LLVM 
> 1.7?  1.6 is quite old by now...
> -Chris

I tried 1.7 version llvm, but the result is even worse, I cannot build llvm 

make[2]: Entering directory `/cygdrive/d/Project/LLVM/llvm-1.7/build/tools/llc'
llvm[2]: Compiling llc.cpp for Release build
llvm[2]: Linking Release executable llc (without symbols)
collect2: ld terminated with signal 11 [Segmentation fault], core dumped
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../i686-pc-cygwin/bin/ld: BFD 
 20050610 assertion fail /netrel/src/binutils-20050610-1/bfd/cofflink.c:1926
make[2]: *** [/cygdrive/d/Project/LLVM/llvm-1.7/build/Release/bin/llc.exe] 
make[2]: Leaving directory `/cygdrive/d/Project/LLVM/llvm-1.7/build/tools/llc'
make[1]: *** [llc/.makeall] Error 2
make[1]: Leaving directory `/cygdrive/d/Project/LLVM/llvm-1.7/build/tools'
make: *** [all] Error 1
I shall skip llc and have another try.

Cygwin build is so slow on my machine.

Also, I tried building LLVM on redhat 9, but have problem even running 

So I want to know your working setting there.

More information about the llvm-dev mailing list