<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On Tue, Sep 19, 2017 at 2:09 PM, Rafael Avila de Espindola <span dir="ltr"><<a href="mailto:rafael.espindola@gmail.com" target="_blank">rafael.espindola@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Rui Ueyama via Phabricator <<a href="mailto:reviews@reviews.llvm.org">reviews@reviews.llvm.org</a>> writes:<br>
<br>
> -struct CieRecord {<br>
> -  EhSectionPiece *Piece = nullptr;<br>
> -  std::vector<EhSectionPiece *> FdePieces;<br>
> -};<br>
> -<br>
>  // Section for .eh_frame.<br>
>  template <class ELFT> class EhFrameSection final : public SyntheticSection {<br>
>    typedef typename ELFT::Shdr Elf_Shdr;<br>
> @@ -88,19 +83,27 @@<br>
>    std::vector<EhInputSection *> Sections;<br>
><br>
>  private:<br>
> +  struct CieRecord {<br>
> +    EhInputSection *Sec = nullptr;<br>
> +    EhSectionPiece *Cie = nullptr;<br>
> +    std::vector<EhSectionPiece *> Fdes;<br>
> +  };<br>
<br>
Why move the struct? It is now in a template, which makes it less<br>
convenient to use.<br></blockquote><div><br></div><div>No strong reason. Since the struct was used only by this class, so I thought moving it inside a local scope of this class would improve readability a bit, but we could keep it as-is.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
I think this is OK, but it includes a few renames which make things<br>
harder to read. Can you for example commit<br>
<br>
-  std::vector<CieRecord *> Cies;<br>
+  std::vector<CieRecord *> CieRecords;<br>
<br>
First and rebase?<br></blockquote><div><br></div><div>Will do. </div></div></div></div>