I mostly included those for api symmetry since I thought it helped readability.  I can remove if it doesn't help though<br><div class="gmail_quote"><div dir="ltr">On Tue, May 9, 2017 at 2:17 PM Rui Ueyama via Phabricator <<a href="mailto:reviews@reviews.llvm.org">reviews@reviews.llvm.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">ruiu added inline comments.<br>
<br>
<br>
================<br>
Comment at: lld/include/lld/Core/Parallel.h:32-33<br>
+<br>
+constexpr sequential_execution_policy seq{};<br>
+constexpr parallel_execution_policy par{};<br>
+<br>
----------------<br>
nit: do you need `{}`?<br>
<br>
<br>
================<br>
Comment at: lld/include/lld/Core/Parallel.h:176<br>
+                "Invalid execution policy!");<br>
+  detail::sequential_sort(Start, End, Comp);<br>
+}<br>
----------------<br>
I think you can remove `detail::sequential_sort` and use `std::sort` instead.<br>
<br>
<br>
================<br>
Comment at: lld/include/lld/Core/Parallel.h:190<br>
+                "Invalid execution policy!");<br>
+  detail::sequential_for_each_n(Begin, End, Fn);<br>
+}<br>
----------------<br>
This function is called once. You can remove the function and inline.<br>
<br>
<br>
<a href="https://reviews.llvm.org/D33016" rel="noreferrer" target="_blank">https://reviews.llvm.org/D33016</a><br>
<br>
<br>
<br>
</blockquote></div>