<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Fri, Feb 3, 2017 at 4:00 PM, Teresa Johnson via Phabricator <span dir="ltr"><<a href="mailto:reviews@reviews.llvm.org" target="_blank">reviews@reviews.llvm.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">tejohnson added inline comments.<br>
<br>
<br>
================<br>
Comment at: lib/IR/Globals.cpp:159<br>
<span class="">+ else {<br>
+ if (StaticFuncStripDirNamePrefix != 0)<br>
+ FileName = stripDirPrefix(FileName, StaticFuncStripDirNamePrefix);<br>
</span>----------------<br>
<span class="">davidxl wrote:<br>
> getGlobalIdentifier is a low level interface. Move this into getPGOFuncName<br>
</span>Rong and I discussed this - putting it here ensures the same naming scheme is used for PGO and for the ThinLTO index. Although for ThinLTO we will likely not want this enabled. I'm not sure if there is a good way to enforce that.<br>
<br></blockquote><div><br></div><div>Ideally we should not couple ThinLTO naming scheme with PGO lookup name scheme -- PGO code should be able to 'reconstruct' the original static function name and then use getPGOFuncName to form the lookup name -- but that is for later.</div><div><br></div><div>For now, it is better to isolate this internal option to the domain of PGO only. </div><div><br></div><div>David</div><div><br></div><div> <br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
<a href="https://reviews.llvm.org/D29512" rel="noreferrer" target="_blank">https://reviews.llvm.org/<wbr>D29512</a><br>
<br>
<br>
<br>
</blockquote></div><br></div></div>