<html>
  <head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <br>
    <br>
    <div class="moz-cite-prefix">On 24.11.2015 01:45, Rui Ueyama wrote:<br>
    </div>
    <blockquote
cite="mid:CAJENXgvKapBRnfwi9jKFJHyQTrHoWQj66nbmr1PG_ERXvP6YoA@mail.gmail.com"
      type="cite">
      <div dir="ltr">
        <div class="gmail_extra">
          <div class="gmail_quote">On Mon, Nov 23, 2015 at 11:40 AM,
            Rafael Espíndola <span dir="ltr"><<a
                moz-do-not-send="true"
                href="mailto:rafael.espindola@gmail.com" target="_blank"><a class="moz-txt-link-abbreviated" href="mailto:rafael.espindola@gmail.com">rafael.espindola@gmail.com</a></a>></span>
            wrote:<br>
            <blockquote class="gmail_quote" style="margin:0 0 0
              .8ex;border-left:1px #ccc solid;padding-left:1ex">On 23
              November 2015 at 13:04, Rui Ueyama via llvm-commits<br>
              <span class=""><<a moz-do-not-send="true"
                  href="mailto:llvm-commits@lists.llvm.org">llvm-commits@lists.llvm.org</a>>
                wrote:<br>
                > ruiu added a comment.<br>
                ><br>
                > I'm not in favor of this change, and I wouldn't do
                that. The previous code was super clear that it errors
                if isInt check fails. Now you have to take a look at the
                definition of checkAArch64OutOfRange function. You saved
                one line per a function call, but it doesn't seem like a
                good tradeoff from code readability point of view.<br>
                <br>
              </span>How about something like<br>
              <br>
              checkIsInt<N>(Val, Msg);<br>
              <br>
              It should be almost as compact as this change and easy to
              read.<br>
            </blockquote>
            <div><br>
            </div>
            <div>That may make sense. I'm not sure if I'll like that
              than the original code, but it's worth a try. </div>
          </div>
          <br>
        </div>
      </div>
    </blockquote>
    The main motivation was to simplify the code that generates error
    messages, like this:<br>
    <br>
    if (Type == R_AARCH64_JUMP26)<br>
        error("Relocation R_AARCH64_JUMP26 out of range");<br>
    error("Relocation R_AARCH64_CALL26 out of range");<br>
    <br>
    Maybe I got a bit carried away. I'll prepare a new patch today.<br>
  </body>
</html>