<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On Mon, Oct 26, 2015 at 1:21 PM, Jim Grosbach <span dir="ltr"><<a href="mailto:grosbach@apple.com" target="_blank">grosbach@apple.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">grosbach added a subscriber: grosbach.<br>
grosbach added a comment.<br>
<br>
Cool. AFAIK, the only reason for the array_pod_sort() before was "seems good enough for now."<br>
<br>
<br>
================<br>
Comment at: lib/MC/StringTableBuilder.cpp:33<br>
@@ +32,3 @@<br>
<span class="">+// because it does not compare characters that we already know the same.<br>
+static void qsort(StringPair **Begin, StringPair **End, int Pos) {<br>
</span>+tailcall:<br>
----------------<br>
Can we use a different name? Function names that collide with the C standard library are bountiful opportunities for confusion later.<br></blockquote><div><br></div><div>Sure.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
Relatedly, perhaps this helper function, or a generalized version of it, should go into STLExtras.h next to array_pod_sort?<br></blockquote><div><br></div><div>That's a good idea. I'll send a code review to you.</div></div></div></div>