<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Jun 12, 2014 at 4:46 PM, Duncan P. N. Exon Smith <span dir="ltr"><<a href="mailto:dexonsmith@apple.com" target="_blank">dexonsmith@apple.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="">> On 2014 Jun 12, at 08:42, Chandler Carruth <<a href="mailto:chandlerc@google.com">chandlerc@google.com</a>> wrote:<br>

><br>
> I'm lacking context sadly. =/<br>
<br>
</div>Idea is:<br>
<br>
  - SwapByteOrder takes args by value and returns swapped bytes.<br>
  - <span class="il">Some</span> users want to swap in place.<br>
  - So, rename SwapByteOrder => getSwappedBytes.<br>
  - Then, add swapByteOrder (which takes and modifies a reference).</blockquote></div><br>Anyways, to directly answer: this sounds reasonable to me, and if you're touching the code I would go ahead and fix the naming convention. The only time I really agree with touching code and preserving the old naming convention is when there is some huge interface convention that would suddenly become inconsistent. The canonical example is IRBuilder.</div>
</div>