<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Feb 4, 2014 at 3:33 PM, Justin Bogner <span dir="ltr"><<a href="mailto:mail@justinbogner.com" target="_blank">mail@justinbogner.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="im">Chandler Carruth <<a href="mailto:chandlerc@gmail.com">chandlerc@gmail.com</a>> writes:<br>
> Introduce SmallPtrSetImpl<T *> which allows insert, erase, count, and<br>
> iteration. This alows the majority of operations to be performed without<br>
> encoding a specific small size. It follows the model of<br>
> SmallVectorImpl<T>.<br>
<br>
</div>There's a lot to be said for following the existing practice, so feel<br>
free to ignore this, but SmallVectorImpl isn't really a very indicative<br>
name for how it's used in the first place. It's just ubiquitous enough<br>
that it isn't worth changing. Maybe a better name from the get-go for<br>
SmallPtrSetImpl would be worthwhile?<br>
<br>
On the other hand, it probably isn't worth bikeshedding about a perfect<br>
name for this.</blockquote></div><br>I actually think a better name would be great, but I'd *much* rather consistency here given how thoroughly the current naming pattern has penetrated the codebases. For a sufficiently better name pattern I'd even be willing to broach the subject of switching the existing names over so that we can have the best of both worlds.</div>
<div class="gmail_extra"><br></div><div class="gmail_extra">The annoying thing is picking a substantially more clear name. Any ideas? I don't really have many.</div><div class="gmail_extra"><br></div><div class="gmail_extra">
We could be clever and have SmallFoo<T, N> inherit from SmallFoo<T> -- if you pass the N you get the concrete derived type, if you don't, you get the basic functionality without a specific size. That is sadly the best (and worst!) idea I have....</div>
</div>