<div dir="ltr"><br><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div class="im"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">

Did you mean:<br>
<br>
for (unsigned i = 0, e = array_lengthof(<u></u>FoldableExtends); i < e; ++i) {<br>
<br>
? It's defined in ADT/STLExtras.h.<br></blockquote><div><br></div></div><div>Indeed I did. My grepping failed to find this, but found a lot of code that looked like what I wrote :-)</div><div>I'll use that when I check-in. </div>

</div></div></div>
</blockquote></div><br></div><div class="gmail_extra" style>Actually:</div><div class="gmail_extra" style><div class="gmail_extra">warning: template argument uses local type '<anonymous struct at</div><div class="gmail_extra">
      /usr/local/google/home/jfb/sandbox/llvm/llvm/lib/Target/ARM/ARMFastISel.cpp:2889:16>' [-Wlocal-type-template-args]</div><div class="gmail_extra">  for (unsigned i = 0, e = array_lengthof(FoldableExtends);</div>
<div class="gmail_extra">                           ^~~~~~~~~~~~~~</div><div><br></div><div style>Would you rather have this in an anonymous namespace, or keep the previous code? I quite like function locals for readability. (also: silly template rules, grr).</div>
</div></div>