Do you mean I should use vector or array instead? Or should I change the name "Tmp"? I understand "Tmp" is not very descriptive, but these registers are used as temporaries to store intermediate results.<br>
<br>Thank you.<br><br><div class="gmail_quote">On Mon, Jul 18, 2011 at 1:22 PM, Jakob Stoklund Olesen <span dir="ltr"><<a href="mailto:stoklund@2pi.dk">stoklund@2pi.dk</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<br>
On Jul 18, 2011, at 12:58 PM, Akira Hatanaka wrote:<br>
<br>
> @@ -819,7 +819,6 @@<br>
>   unsigned Tmp2 = RegInfo.createVirtualRegister(RC);<br>
>   unsigned Tmp3 = RegInfo.createVirtualRegister(RC);<br>
>   unsigned Tmp4 = RegInfo.createVirtualRegister(RC);<br>
> -  unsigned Tmp5 = RegInfo.createVirtualRegister(RC);<br>
>   unsigned Tmp6 = RegInfo.createVirtualRegister(RC);<br>
>   unsigned Tmp7 = RegInfo.createVirtualRegister(RC);<br>
>   unsigned Tmp8 = RegInfo.createVirtualRegister(RC);<br>
<br>
Interesting naming scheme. Please fix that. (I know you didn't do it.)<br>
<br>
<a href="http://llvm.org/docs/CodingStandards.html#ll_naming" target="_blank">http://llvm.org/docs/CodingStandards.html#ll_naming</a><br>
<br>
Thanks,<br>
<font color="#888888">/jakob<br>
<br>
</font></blockquote></div><br>