<div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"> } else if (Operands[i].isFP()) {<br>
OS << "f" << i;<br>
} else {<br>
- assert("Unknown operand kind!");<br>
- abort();<br>
+ llvm_unreachable("Unknown operand kind!");<br>
}<br>
if (i + 1 != e)<br>
OS << ", ";<br></blockquote><div><br></div><div>Just wondering about coding conventions - would it be more appropriate to change this from:<br> else if (cond) { ... } else { /* unreachable */ }<br>
to:<br> else { assert(cond); ... };<br>This would be marginally more efficient in release builds, potentially. </div></div><br>