<div class="gmail_quote">2009/8/21 Reid Kleckner <span dir="ltr"><<a href="mailto:rnk@mit.edu">rnk@mit.edu</a>></span><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="im">> This makes emitAlignment dead then, right? Why not change emitAlignment to<br>
> write the nops, and not take an extra parameter?<br>
<br>
</div>No, the JITEmitter uses it for aligning the constant pool, and<br>
MachineCodeEmitters could potentially use it in other ways that don't<br>
actually require that the memory be initialized. The question is, if<br>
we don't think it matters, should they be initialized to garbage, or<br>
to zeros? I'd prefer uninitialized in release mode, and garbage in<br>
debug mode, which is what this patch implements.</blockquote><div><br>That makes sense to me.<br> </div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="im">
> Also, don't reimplement RoundUpToAlignment() as AlignPtr().<br>
<br>
</div><br>Such a thing exists? Awesome. There's some serious proliferation of<br>
this little alignment bithack, and it involves these ugly casts to<br>
uintptr_t that are hard to read.</blockquote><div><br>Yes. To quote myself from my first email in the thread, "Please use RoundUpToAlignment() from llvm/Support/MathExtras.h."<br><br>Please fix that and then commit. And then watch the buildbots.<br>
</div></div><br>Nick<br><br>