[PATCH] D148836: [X86] Use "l" prefix for data sections under medium/large code model

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed May 24 19:46:49 PDT 2023


MaskRay accepted this revision.
MaskRay added a comment.

Looks great! According to https://groups.google.com/g/x86-64-abi/c/jnQdJeabxiU , `-mcmodel=large` sections should be able to use `.ldata` as well, even though GCC hasn't made the change yet.



================
Comment at: llvm/test/CodeGen/X86/code-model-elf-sections.ll:15
+
+; LARGE:      Name: .ldata
+; LARGE-NEXT: Type: SHT_PROGBITS
----------------
Consider `llvm-readelf -S`. The tabular output is easier to read.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D148836/new/

https://reviews.llvm.org/D148836



More information about the llvm-commits mailing list